Updating to ESXi 4.1 Error : Failed to read the upgrade package metadata.xml

You have issue upgrading from ESXi 4.0 Update 2 to ESXi 4.1 you have the error :  Failed to read the upgrade package metadata.xml

Basically the problem is related to ESXi doesn’t support the SSH Shell.
To activate the SSH Shell : 

1. At the console of the ESXi host, press ALT-F1 to access the console window.
2. Enter unsupported in the console and then press Enter. You will not see the text you type in.
3. If you typed in unsupported correctly, you will see the Tech Support Mode warning and a password prompt. Enter the password for the root login.
4. You should then see the prompt of ~ #. Edit the file inetd.conf (enter the command vi /etc/inetd.conf).
5. Find the line that begins with #ssh and remove the #. Then save the file. If you’re new to using vi, then move the cursor down to #ssh line and then press the Insert key. Move the cursor over one space and then hit backspace to delete the #. Then press ESC and type in :wq to save the file and exit vi. If you make a mistake, you can press the ESC key and then type it :q! to quit vi without saving the file.
6. Once you’ve closed the vi editor, run the command /sbin/services.sh restart to restart the management services. You’ll now be able to connect to the ESXi host with a SSH client. But for me I was force to Reboot the Server.

  • Upload the package with the VI client to a folder on the ESX Server
  • Put the server in maintenance mode
  • Connect to the Shell and fo into the folder where you upload the package
  • at the prompt run :     esxupdate update –m metadata.zip
  • Reboot and enjoy !  🙂

I will not take the credit for it I keep the steps in case their website goes down, for a more details go to : 
http://blog.vmpros.nl/2010/07/15/vmware-failed-to-read-the-upgrade-package-metadata-xml-upgrading-to-esxi-4-1/

Leave a Reply